summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFFY002018-07-10 13:17:28 +0100
committerFFY002018-07-10 13:17:28 +0100
commit1a9873219269ba52653814c73d29663fdc2bca8c (patch)
tree7c762f1e3dceea1708df87f96acc47b6e8d267dc /PKGBUILD
parentb4ba3a86517d804159e9c5656ade905c18ce0f86 (diff)
downloadaur-1a9873219269ba52653814c73d29663fdc2bca8c.tar.gz
pkgbuild: specify submodules
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6786c2e49cee..fa109e0b6f12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,33 @@ pkgver=7.1.0
_gitver=$pkgver-exp3
pkgrel=1
pkgdesc="Privacy enhanced BitTorrent client with P2P content discovery"
-url="http://www.tribler.org/"
-arch=(any)
+url="https://www.tribler.org/"
+arch=('any')
license=('LGPL3')
-depends=('python2-cryptography' 'python2-feedparser' 'python2-apsw' 'python2-cherrypy' 'python2-plyvel' 'python2-pillow' 'python2-pyqt5' 'qt5-svg' 'phonon-qt5-vlc' 'python2-feedparser' 'python2-chardet' 'python2-psutil' 'python2-meliae'
-'python2-decorator' 'python2-netifaces' 'python2-requests' 'python2-twisted' 'libsodium' 'libtorrent-rasterbar' 'python2-m2crypto' 'python2-configobj' 'python2-matplotlib' 'python2-service_identity' 'python2-keyring' 'python2-keyrings-alt')
+depends=('python2-cryptography' 'python2-feedparser' 'python2-apsw' 'python2-cherrypy' 'python2-plyvel'
+ 'python2-pillow' 'python2-pyqt5' 'qt5-svg' 'phonon-qt5-vlc' 'python2-feedparser' 'python2-chardet'
+ 'python2-psutil' 'python2-meliae' 'python2-decorator' 'python2-netifaces' 'python2-requests'
+ 'python2-twisted' 'libsodium' 'libtorrent-rasterbar' 'python2-m2crypto' 'python2-configobj'
+ 'python2-matplotlib' 'python2-service_identity' 'python2-keyring' 'python2-keyrings-alt')
optdepends=('vlc: for internal video player')
makedepends=('python2-setuptools')
provides=('tribler' 'python2-pyipv8')
conflicts=('tribler' 'python2-pyipv8')
-source=("git+https://github.com/Tribler/tribler.git#tag=v$_gitver")
-sha256sums=('SKIP')
+source=("git+https://github.com/Tribler/tribler.git#tag=v$_gitver"
+ 'git+https://github.com/Tribler/dispersy.git'
+ 'git+https://github.com/devos50/pymdht.git'
+ 'git+https://github.com/spesmilo/electrum'
+ 'git+https://github.com/Tribler/py-ipv8.git')
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
prepare() {
cd "$srcdir"/$pkgname
- git submodule update --init --recursive
+ git submodule init
+ git config submodule.Tribler/dispersy.url "$srcdir"/dispersy
+ git config submodule.Tribler/Core/DecentralizedTracking/pymdht.url "$srcdir"/pymdht
+ git config submodule.electrum.url "$srcdir"/electrum
+ git config submodule.py-ipv8.url "$srcdir"/py-ipv8
+ git submodule update
}
build () {