summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFFY002018-08-20 19:47:23 +0100
committerFFY002018-08-20 19:47:23 +0100
commit458d4bd426b81e0e4c8d1f7faee9d0b8a6bfa533 (patch)
tree8942144c8dadadd45a5837910f5f75d75b0a0134 /PKGBUILD
parente5d1f27f6f1e617d24c6e589b59fe0369ee34023 (diff)
downloadaur-458d4bd426b81e0e4c8d1f7faee9d0b8a6bfa533.tar.gz
pkgbuild: add missing dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 783455a96596..73f5a6b57451 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ depends=('python2-cryptography' 'python2-feedparser' 'python2-apsw' 'python2-che
'python2-psutil' 'python2-meliae' 'python2-decorator' 'python2-netifaces' 'python2-requests'
'python2-twisted' 'libsodium' 'libtorrent-rasterbar' 'python2-m2crypto' 'python2-configobj'
'python2-matplotlib' 'python2-service-identity' 'python2-keyring' 'python2-keyrings-alt'
- 'python2-libnacl' 'python2-contextlib2' 'python2-zc.lockfile' 'python2-datrie')
+ 'python2-libnacl' 'python2-contextlib2' 'python2-zc.lockfile' 'python2-datrie' 'python2-networkx')
optdepends=('vlc: for internal video player')
makedepends=('python2-setuptools' 'git')
provides=('python2-pyipv8')
@@ -70,6 +70,9 @@ package() {
cp -dr --no-preserve=ownership twisted "$pkgdir"/usr/share/tribler
cp -dr --no-preserve=ownership electrum "$pkgdir"/usr/share/tribler
+ # Remove tests
+ find "$pkgdir" -type d -name "test" -name "tests" -exec rm -rf {} \;
+
# Install systemd files
install -Dm 644 systemd/anontunnel_helper@.service "$pkgdir"/usr/lib/systemd/system/anontunnel_helper@.service
install -Dm 644 systemd/tribler.service "$pkgdir"/usr/lib/systemd/system/tribler.service