summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathon Fernyhough2021-07-31 19:54:21 +0100
committerJonathon Fernyhough2021-07-31 19:54:21 +0100
commitf1bb1f92bdb7241cba0c8b98e0087db1baedd234 (patch)
treeb00fd7b0ff6c87e649a65ebad696cd8e6cbbda48 /PKGBUILD
parentc604b2b477dcc730178dd17eacaabdc0002ce48d (diff)
downloadaur-trickle.tar.gz
Include patch to fix build with -Werror=format-security
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 715333b5283e..90486cc1e99a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: Jonathon Fernyhough <jonathon at_manjaro_dot org>
+# Maintainer: Jonathon Fernyhough <jonathon+m2x+dev>
# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
# Contributor: Romain Bouchaud-Leduc <r0m1.bl@camaris.org>
pkgname=trickle
pkgver=1.07
-pkgrel=11
+pkgrel=12
pkgdesc="Lightweight userspace bandwidth shaper"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/mariusae/trickle"
@@ -12,22 +12,27 @@ license=('BSD')
depends=('libevent' 'libtirpc')
_commit=a2aeb9f30aa3c651580b9be9ba3c9c13bf51a416 # "import of trickle 1.07"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mariusae/trickle/archive/${_commit}.tar.gz"
- "fix-crasher.patch")
+ "fix-crasher.patch"
+ "$url/commit/20f221f166fc03323ed28dc3cad0b0da2c879513.patch")
sha256sums=('b07ffdff831d11972dc802a4fc2d4000af844933b39ad7f88de20a2866a55f37'
- '495aeb95039dcdeb3bfde46c40b3391fe2416ec51678a1ded9bbeced6f6d1349')
+ '495aeb95039dcdeb3bfde46c40b3391fe2416ec51678a1ded9bbeced6f6d1349'
+ '432194c2a25e934a865a06de9fa876545431a1729028ca1a60943554865fb40c')
prepare() {
- cd "${srcdir}/${pkgname}-${_commit}"
+ cd $pkgname-$_commit
# FS#27549
sed -i 's|^_select(int|select(int|' trickle-overload.c
# FS#35872
- patch -Np1 -i "${srcdir}/fix-crasher.patch"
+ patch -Np1 -i ../fix-crasher.patch
+
+ # Fix build with -Werror=format-security, https://github.com/mariusae/trickle/commit/20f221f166fc03323ed28dc3cad0b0da2c879513
+ patch -Np1 -i ../20f221f166fc03323ed28dc3cad0b0da2c879513.patch
}
build() {
- cd "${srcdir}/${pkgname}-${_commit}"
+ cd $pkgname-$_commit
CPPFLAGS+=" -I/usr/include/tirpc/"
LDFLAGS+=" -ltirpc"
@@ -40,8 +45,8 @@ build() {
}
package(){
- cd "${srcdir}/${pkgname}-${_commit}"
+ cd $pkgname-$_commit
make DESTDIR="${pkgdir}" install
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 -t "${pkgdir}"/usr/share/licenses/${pkgname}/ LICENSE
}