summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesse Jaara2024-03-18 11:42:45 +0200
committerJesse Jaara2024-03-18 11:42:45 +0200
commit3aed4555050f2e664399767a60a3af45d807547b (patch)
tree54a226e7f2be128e5f5201dc10295d735089bdcf /PKGBUILD
parent45408e4627b4a8a003e10dd77b3b1bb24fc123e5 (diff)
downloadaur-trid.tar.gz
Improve package
* Added the needed `LANG=c` hack to the trid script * Improved update script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e9cf8b18ec2d..f6464035c268 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,30 @@
pkgname=trid
pkgver=2.24
-pkgrel=3
+pkgrel=4
pkgdesc="An utility designed to identify file types from their binary signatures"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://mark0.net/soft-trid-e.html"
license=('CUSTOM')
depends=('python')
install=trid.install
+validpgpkeys=('7EFFF01538C2BE8937BDAF52FABE6DB9D3807047')
+
source=(trid.sh
update-trid-defs.sh
update-trid-defs.service
update-trid-defs.timer
- triupdate-1.00.zip::http://mark0.net/download/tridupdate.zip)
-
-source_i686=(trid-${pkgver}-i686.zip::http://mark0.net/download/trid_linux.zip)
-source_x86_64=(trid-${pkgver}-x86_64.zip::http://mark0.net/download/trid_linux_64.zip)
-
-md5sums=('fe447a9fb6da5591ad72bf17e77084ae'
- '3d7ab5a0cb8a52fa1cfd965267356191'
- '3acd810a05f49c9dc586e964aea90146'
- '2ea012671b50e0761cbc4bbec820952e'
- '9e775c9b773499cd9d7b4712800968af')
-md5sums_i686=('e250feae78ac8e5a5523d044669bba96')
-md5sums_x86_64=('75078cdd077c71b89cc1956525a09649')
+ triupdate-1.10.zip::http://mark0.net/download/tridupdate.zip
+ trid-${pkgver}-x86_64.zip::http://mark0.net/download/trid_linux_64.zip
+ trid-${pkgver}-x86_64.zip.asc::http://mark0.net/download/trid_linux_64.zip.asc)
+b2sums=('acd89bc33a6f00d2709219fa6f67343680384f320860b7e9e3cc0ead6dddf0ebcc953fbf1a8d2e4d4f2a705b3c0cc20a12ec8bfa6dd849f8235b323cd13575f8'
+ 'db8916665fbaef5e02993ccaa3098f0906ae5e16862b853de84336533cd3431f0a15b7fd1de5ec0d5f8e50f4444946db718a8597e0079e3641a1d3468134bdfb'
+ '00787de3be0a3244669485022015bc1376683dceb80d18194aef9be90a8f77ee4faa4c897f1c60ec06b182bb46fd8e7ee1d27ca0f202a619cee01a4f1a1051be'
+ 'ad09bd81ba2855ee9a729320ebf0a1528124cc998e6af3f9bfff9524a736d05c77808c7b300f53c9632d5d420bbe9c85cb6e0bee1d32c08df1bedd336e4a98a7'
+ '41d43bb2587a3d08030d0f4250027d62876338e56c2d4bafd5adeca343ad678feaf844e7a12e8a0409262a849d04d00a1c352359b619ea7621f81bb91c0066f0'
+ 'c28e12d6b308a243beeb030dbc09582b703332e9d87d9d6f9ee5f1c7da6e5ce7b57867db00fcfeb30c9ebea8379aac83a16b7ad11c3864dec329e1d0251b05d1'
+ 'SKIP')
package() {
cd "${srcdir}"