summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Diehl2020-03-03 12:15:57 +0100
committerMartin Diehl2020-03-03 12:15:57 +0100
commit00caded40a27cd50b24b65595791c06aa011d29d (patch)
tree67b45878aac50d9f3c77c851aabb8cac69e4bd84 /PKGBUILD
parent7c8b1400e3d8b0311f17916447bea8ca0bd3e2f6 (diff)
downloadaur-00caded40a27cd50b24b65595791c06aa011d29d.tar.gz
2 fixes, credits to alexei for reporting
do not escape # in quoted strings, bc needed for building
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea9ca830fe8d..62811e281b7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,16 @@ depends=('python' 'lapack' 'boost' 'netcdf' 'libmatio' 'libx11' 'hdf5-openmpi')
makedepends=('gcc-fortran' 'perl' 'blas' 'cmake' 'doxygen')
conflicts=('gtest')
checkdepends=('cmake')
-source=("https://github.com/trilinos/Trilinos/archive/trilinos-release-$_pkgver.tar.gz")
-sha256sums=('7d2e1a1a3e2d2ce78bb248c63411fed5007c827b87cadee3d13c1a45c09a89cf')
+source=("https://github.com/trilinos/Trilinos/archive/trilinos-release-$_pkgver.tar.gz"
+ "Makefile.kokkos.patch")
+sha256sums=('7d2e1a1a3e2d2ce78bb248c63411fed5007c827b87cadee3d13c1a45c09a89cf'
+ '64130011dd70f3be1133c0943be458a7d4f6fa799e6bd47a6294300ced6d827a')
+
+prepare() {
+ cd Trilinos-trilinos-release-12-18-1
+ patch --forward --strip=1 --input="${srcdir}/Makefile.kokkos.patch"
+}
+
build() {
cd Trilinos-trilinos-release-"$_pkgver"