summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwangjiezhe2017-07-29 16:52:28 +0800
committerwangjiezhe2017-07-29 16:52:28 +0800
commitf813b6432bff48e66b0b456feeba90896c47b7ae (patch)
tree90b6e42c76498dcb24a754562e9adfffc0101444 /PKGBUILD
parent190261853abeb151a5959da56be4ac61788efda8 (diff)
downloadaur-f813b6432bff48e66b0b456feeba90896c47b7ae.tar.gz
trilinos-git 12.12.0.gd3b096f4f1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd6d7dba2a70..011fddf403e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@
pkgname=trilinos-git
_pkgname=Trilinos
-pkgver=r73423.32d771b900
+pkgver=12.12.0.gd3b096f4f1
pkgrel=1
pkgdesc="An effort to develop algorithms and enabling technologies within an object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems."
arch=('i686' 'x86_64')
@@ -36,7 +36,8 @@ options=('ccache')
pkgver() {
cd "${srcdir}/${_pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long | sed -e 's/root-of-trilinos-release-//' -e 's/branch-//' -e 's/^v//;s/-/./g'
}
build() {