summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHanFox2015-08-03 10:05:49 +0100
committerHanFox2015-08-03 10:05:49 +0100
commitde1ac83c59a02940c57b5e0921a554c97c4c6ccc (patch)
treef695733492bcc7b6f2b0eda90d4f94b43636b606 /PKGBUILD
parent5670eaf1cbef98c0669f29e04353ff2920f036da (diff)
downloadaur-de1ac83c59a02940c57b5e0921a554c97c4c6ccc.tar.gz
add check for libzip 2 and make symlink if necessary
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53ccbe8622cc..88dcb8464d1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=trillian
pkgver=2.0.0.5
-pkgrel=1
+pkgrel=2
pkgdesc="A commercial, multi-protocol and cross-platform IM client"
arch=('i686' 'x86_64')
url="https://www.trillian.im"
@@ -21,4 +21,10 @@ md5sums_i686=('a35ecdf0da66c240d0b604d7fa76cc5b')
package() {
tar xzvf "$srcdir/data.tar.gz" -C "$pkgdir/"
+
+ libzip_link=/usr/lib/libzip.so.2
+ if [ ! -f "$libzip_link" ]; then
+ mkdir -p $pkgdir/usr/lib
+ ln -s /usr/lib/libzip.so $pkgdir$libzip_link
+ fi
} \ No newline at end of file