summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2018-04-29 20:41:56 +0430
committerMohammadreza Abdollahzadeh2018-04-29 20:41:56 +0430
commit08fffdba1266c9b7fbd59ff9a43f021c9b2dba08 (patch)
tree36183f64d15b82ba7867ea279ab04e5aab107fc9 /PKGBUILD
parent9afa776f4229f72c55d16892530a5b93746c5b6b (diff)
downloadaur-trisquel-wallpapers.tar.gz
update to v8.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a520eeb06bc..1a785db23bd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,24 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
-
pkgname=trisquel-wallpapers
-pkgver=7.0_1
-pkgrel=3
+pkgver=8.0_1
+pkgrel=1
pkgdesc="The default Wallpapers for Trisquel."
url="http://trisquel.info"
arch=('any')
license=('GPL')
source=("http://archive.trisquel.info/trisquel/pool/main/t/trisquel-wallpapers/${pkgname}_${pkgver/_/-}.tar.gz")
-md5sums=('a4454ea0eb82977dd239468af80c5300')
-
+sha256sums=('c130095a3609e726d72770e96e9b823d2369d5c1634ec2ebd9291896478c5ea8')
+
+prepare() {
+ cd ${pkgname}
+ sed -i 's_/usr/share/backgrounds/_/usr/share/backgrounds/trisquel/_g' ./data/usr/share/gnome-background-properties/trisquel-wallpapers.xml
+ sed -i 's/gnome-wp-list.dtd/mate-wp-list.dtd/' ./data/usr/share/gnome-background-properties/trisquel-wallpapers.xml
+}
package() {
- install -d ${pkgdir}/usr/share/{backgrounds/trisquel,gnome-background-properties,mate-background-properties}
- cp ${srcdir}/trisquel-wallpapers/data/usr/share/backgrounds/* ${pkgdir}/usr/share/backgrounds/trisquel/
- sed -i 's_/usr/share/backgrounds/_/usr/share/backgrounds/trisquel/_g' ${srcdir}/trisquel-wallpapers/data/usr/share/gnome-background-properties/trisquel-wallpapers.xml
- cp ${srcdir}/trisquel-wallpapers/data/usr/share/gnome-background-properties/trisquel-wallpapers.xml ${pkgdir}/usr/share/gnome-background-properties/
- sed -i 's/gnome-wp-list.dtd/mate-wp-list.dtd/' ${srcdir}/trisquel-wallpapers/data/usr/share/gnome-background-properties/trisquel-wallpapers.xml
- cp ${srcdir}/trisquel-wallpapers/data/usr/share/gnome-background-properties/trisquel-wallpapers.xml ${pkgdir}/usr/share/mate-background-properties/
+ cd ${pkgname}
+ install -d ${pkgdir}/usr/share/{backgrounds/trisquel,gnome-background-properties,mate-background-properties}
+ cp ./data/usr/share/backgrounds/* ${pkgdir}/usr/share/backgrounds/trisquel/
+ cp ./data/usr/share/gnome-background-properties/trisquel-wallpapers.xml ${pkgdir}/usr/share/gnome-background-properties/
+ cp ./data/usr/share/gnome-background-properties/trisquel-wallpapers.xml ${pkgdir}/usr/share/mate-background-properties/
}
+# vim:set ts=2 sw=2 et: