summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosé Ángel Soler Ortiz2021-04-20 19:22:03 +0200
committerJosé Ángel Soler Ortiz2021-04-20 19:22:03 +0200
commit2be03c4176f967d90572b465628ca00e1bce86d0 (patch)
tree3be22389dfbb201deb490f22ee06fbfcd0d52fd4 /PKGBUILD
parent343ec0e71756dd4be715f80561e0c695528faa01 (diff)
downloadaur-trng4-git.tar.gz
Upstream handles static and dynamic as different CMake targets instead of treating them as the same target with different properties.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 430628a6a5d0..64a2863c2926 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,6 +13,8 @@ checkdepends=('boost-libs')
conflicts=('trng4')
provides=('trng4')
source=('git+https://github.com/rabauke/trng4')
+# Upstream handles static and dynamic as different CMake targets instead of treating them as the same target with different properties.
+options=(staticlibs)
sha512sums=('SKIP')
pkgver() {
@@ -26,7 +28,7 @@ build() {
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-Wno-dev
- make -C "trng4/build" trng4_shared test_all
+ make -C "trng4/build" trng4_shared trng4_static test_all
}
check() {