summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2017-07-05 22:00:10 -0400
committerChris Severance2017-07-05 22:00:10 -0400
commit910203984f22ff7a330eda81f7b9a7aade5e9053 (patch)
treeca0815f12a50e4349e9028374e3beb70be682f31 /PKGBUILD
parent8be94509ff858f25999dd768606c6b0cef6ea7ca (diff)
downloadaur-910203984f22ff7a330eda81f7b9a7aade5e9053.tar.gz
Fix sed mistake
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d56b773e0012..fd15d84e87bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -108,7 +108,7 @@ if [ "${_opt_SSL}" -ne 0 ]; then
depends+=('openssl')
fi
makedepends=('awk' 'sed' 'diffutils' 'patch')
-conflicts=('dgrp') # running together with dgrp eventually jams up trueport
+#conflicts=('dgrp') # running together with dgrp eventually jams up trueport
backup=(etc/trueport/{config.tp,pktfwdcfg.tp,sslcfg.tp})
options=('!docs' '!emptydirs' '!strip')
install="${pkgname}-install.sh"
@@ -166,7 +166,7 @@ prepare() {
sed -e 's:\( fixed_ttyname,"\)px\(" \):'"\1${_opt_masterttypfx}\2:g" \
-e 's:\( slave_ttyname, "/dev/\%s\%04d","\)tx\(",\):'"\1${_opt_slavettypfx}\2:g" \
-i 'trueportd.c'
- sed -e 's:^\(FORMAT\)=tx:'"\1=${_opt_slavettypfx}:g" 'addports'
+ sed -e 's:^\(FORMAT\)=tx:'"\1=${_opt_slavettypfx}:g" -i 'addports'
sed -e 's:^\(FULLTTYNAME\="\)tx:'"\1${_opt_slavettypfx}:g" \
-e 's:\(grep "\)tx:'"\1${_opt_slavettypfx}:g" \
-i 'tplogin'
@@ -203,9 +203,7 @@ package() {
# I don't want Linux version info showing on AUR web. After a few months 'linux<0.0.0' makes it look like an out of date package.
local _kernelversionsmall="$(uname -r)"
_kernelversionsmall="${_kernelversionsmall%%-*}"
- if [ "${_kernelversionsmall%\.0\.0}" != "${_kernelversionsmall}" ]; then # trim 4.0.0 -> 4.0
- _kernelversionsmall="${_kernelversionsmall%\.0}"
- fi
+ _kernelversionsmall="${_kernelversionsmall%\.0}" # trim 4.0.0 -> 4.0, 4.1.0 -> 4.1
# prevent the mksrcinfo bash emulator from getting these vars!
eval 'conf''licts=("linux>${_kernelversionsmall}" "linux<${_kernelversionsmall}")'
eval 'dep''ends+=("linux=${_kernelversionsmall}")'