summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTodd E Johnson2021-12-16 09:49:50 -0600
committerTodd E Johnson2021-12-16 09:49:50 -0600
commit1496671f64c6556d38bf0ab9b0bdea76d1ffdac1 (patch)
treec6dd52cba337dbe0595b2a717aa14d706267a163 /PKGBUILD
parent9e09642894cb7cc1f4fdcdfb471dd67ea74fa6fd (diff)
downloadaur-1496671f64c6556d38bf0ab9b0bdea76d1ffdac1.tar.gz
Update 4.2.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b923ab9bfd8f..3b86afffcb6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Todd E Johnson <todd@toddejohnson.net>
options=(!buildflags)
pkgname=trunk-recorder
-pkgver=4.1.1
+pkgver=4.2.2
_dlpkgver=${pkgver}
pkgrel=1
pkgdesc="Records calls from a Trunked Radio System (P25 & SmartNet)"
@@ -14,15 +14,18 @@ optdepends=()
source=("https://github.com/robotastic/trunk-recorder/archive/v${_dlpkgver}.tar.gz"
'trunk-recorder.service'
'trunk-recorder.sysusers'
+ '582-system-boost-foreach.patch'
'trunk-recorder.tmpfiles')
-sha256sums=('d4814d35e82b3e335f5e435856459c370ac7aa29f8306f771e9f926350774e3c'
+sha256sums=('2c9838ed4258c36d3a867b95f7ca74d37b77751945b81c22ea8b474b14e9dec0'
'78bb66aa30af3395c2eddcafa3e59f65e59a328e04a093bb849a83cdedf01a0d'
'f2e06d333ec8a64c869a9cf369015bf6e0b9819d2af259b4d1c411ed3cca78f8'
+ '0bc0e34a9fc883baa98e0d698fe21a04a3034c39fe81ad2f1c855dda804589a3'
'c20344ba366fcab3f3552e2b5e537f394406ab634f35c2b8858423ffa63fd0e8')
prepare() {
rm -rf build
mkdir build
+ patch --directory="${pkgname}-${_dlpkgver}" --forward --strip=1 --input="${srcdir}/582-system-boost-foreach.patch"
}
build() {
cd build