summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSam A. Horvath-Hunt2023-04-21 20:04:55 +0100
committerSam A. Horvath-Hunt2023-04-21 20:04:55 +0100
commit61d221756c5c1d6d25c4d0296498d56b598f4e43 (patch)
tree2064ed7a67d8fa5e5ea1d0e64f6b59ab384f91dd /PKGBUILD
parent9c3932255d68db376d9a515f0ddeee431d200c6d (diff)
downloadaur-tshm-bin.tar.gz
0.4.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e4091fa5155..26c30f0bc416 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Sam A. Horvath-Hunt <hello@samhh.com>
pkgname=tshm-bin
-pkgver=0.4.0
-pkgrel=2
+pkgver=0.4.2
+pkgrel=1
pkgdesc="Parser and formatter for TypeScript declarations that outputs HM-style type signatures"
url="https://github.com/samhh/tshm"
arch=("x86_64")
license=("MIT")
source=(
- "$url/releases/download/$pkgver/tshm-linux-amd64"
+ "$url/releases/download/$pkgver/tshm-$pkgver-linux-x86_64"
"LICENSE"
)
-sha256sums=('ae8b310915be27b697cd64a2601b716007081b12d9538657c455d84a6f85d60e'
+sha256sums=('733041552fcdfc09e47f2897690f88edc194a8cd76e21ec7b79ac53c93008c2d'
'3440871ff80806ee4369048b13f1557aa609ca9f655040c44a219d4b844425ba')
package() {
- install -Dm755 "tshm-linux-amd64" "$pkgdir/usr/bin/tshm"
+ install -Dm755 "tshm-$pkgver-linux-x86_64" "$pkgdir/usr/bin/tshm"
install -Dm644 "./LICENSE" "$pkgdir/usr/share/licenses/tshm/LICENSE"
}