summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSam A. Horvath-Hunt2021-07-23 17:02:20 +0100
committerSam A. Horvath-Hunt2021-07-23 17:03:52 +0100
commit9c3932255d68db376d9a515f0ddeee431d200c6d (patch)
tree2323166b26b48b25a971bfa265cdf9c1a77cad2f /PKGBUILD
parentd2afd7b879c4f76aa39dedbbb11240a5172969cc (diff)
downloadaur-9c3932255d68db376d9a515f0ddeee431d200c6d.tar.gz
0.4.0-2
Packages the license locally to reduce unneeded downloading. Formatting change with the checksums is as a result of now using the updpkgsums utility.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38c3c6be8d5c..7e4091fa5155 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,20 @@
pkgname=tshm-bin
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Parser and formatter for TypeScript declarations that outputs HM-style type signatures"
-url="https://github.com/samhh/tshm/"
+url="https://github.com/samhh/tshm"
arch=("x86_64")
license=("MIT")
source=(
"$url/releases/download/$pkgver/tshm-linux-amd64"
- "$url/archive/$pkgver.tar.gz"
-)
-sha256sums=(
- "ae8b310915be27b697cd64a2601b716007081b12d9538657c455d84a6f85d60e"
- "a40b8e8babfa7a70cdd290f2049c15ee687c3627188b0d1b79aa24f8758d4a8d"
+ "LICENSE"
)
+sha256sums=('ae8b310915be27b697cd64a2601b716007081b12d9538657c455d84a6f85d60e'
+ '3440871ff80806ee4369048b13f1557aa609ca9f655040c44a219d4b844425ba')
package() {
install -Dm755 "tshm-linux-amd64" "$pkgdir/usr/bin/tshm"
- install -Dm644 "$srcdir/tshm-${pkgver}/LICENSE" "$pkgdir/usr/share/licenses/tshm/LICENSE"
+ install -Dm644 "./LICENSE" "$pkgdir/usr/share/licenses/tshm/LICENSE"
}