summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathan Liu2015-06-19 12:01:56 +1000
committerJonathan Liu2015-06-19 12:01:56 +1000
commit2a46ade73699449a838e4cdb0d73c5eed9f72507 (patch)
treed6dc7fbe208f06a4f47d2ff40e79ae1fced6f457 /PKGBUILD
downloadaur-2a46ade73699449a838e4cdb0d73c5eed9f72507.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..972f16a11670
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jonathan Liu <net147@gmail.com>
+pkgname=ttcp
+pkgver=20100419
+pkgrel=1
+pkgdesc="TCP benchmarking tool"
+arch=('i686' 'x86_64')
+url="http://www.pcausa.com/Utilities/pcattcp.htm"
+license=('custom:Public Domain')
+depends=('glibc')
+source=("http://www.pcausa.com/Utilities/pcattcp/LinuxTTCP.zip"
+ "LICENSE")
+md5sums=('5b4707910c24fec212609f862bc53749'
+ 'd8d09df3d799fec1b0b8a080948ffbb2')
+
+build() {
+ cd "${srcdir}/LinuxTTCP"
+ [ -f makefile ] && rm -f makefile
+ make ttcp
+}
+
+package() {
+ cd "$srcdir/LinuxTTCP"
+ install -D -m755 ttcp "${pkgdir}/usr/bin/ttcp"
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/ttcp/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: