summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraianshume2023-05-25 12:55:06 +0530
committeraianshume2023-05-25 12:55:06 +0530
commit98e3252683b0d14b438e715594a675a4f2782cf6 (patch)
treeca7acff1bbcdceb88d3d96cce5e8849e5c0843f7 /PKGBUILD
downloadaur-98e3252683b0d14b438e715594a675a4f2782cf6.tar.gz
ready
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29cc5b72cf70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=ttf-apple-fonts
+pkgver=1.0
+pkgrel=1
+pkgdesc="Collection of official SF Pro, SF Display, SF Mono Apple Fonts"
+pkgbase=ttf-apple-fonts
+arch=('any')
+url="https://github.com/gxanshu/ttf-apple-fonts"
+license=('GPL')
+
+source=("https://github.com/gxanshu/ttf-apple-fonts/releases/download/Fonts/fonts.zip")
+sha256sums=('8a6d9d53019aa52c1b7be6c0a07cadbc0ff9929d3b8945f7fcee9ee519d900fe')
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir/usr/share/fonts/apple-fonts"
+ cp fonts.zip "$pkgdir/usr/share/fonts/apple-fonts/"
+
+ cd "$pkgdir/usr/share/fonts/apple-fonts"
+ unzip fonts.zip
+ rm fonts.zip
+
+ find . -type f -name '*.otf' -exec install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
+}