summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSotiris Lamprinidis2020-01-14 13:20:50 +0100
committerSotiris Lamprinidis2020-01-14 13:21:55 +0100
commite6ad76ec12fe12879b4665e9f2dd7adc0dd9be9c (patch)
treea4fe6607e1b160111eb7c579b4ffab026299b608 /PKGBUILD
downloadaur-e6ad76ec12fe12879b4665e9f2dd7adc0dd9be9c.tar.gz
Initial package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b5ef32e2872
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sotiris Lamprinidis <sot.lampr at gmail dot com>
+
+pkgname=ttf-cavafy-script
+pkgver=1.1
+pkgrel=0
+pkgdesc="Typeface based on the calligraphic style of the alexandrian poet C. P. Cavafy"
+arch=('any')
+url="https://www.onassis.org/initiatives/cavafy-archive/cavafy-script"
+license=('custom:cc-by-nc-nd-4.0')
+depends=('fontconfig' 'xorg-font-utils')
+provides=('ttf-font')
+source=('https://github.com/onassis-org/cavafy-script/archive/v1.1.zip'
+ 'https://creativecommons.org/licenses/by-nc-nd/4.0/legalcode.txt')
+md5sums=('3769277f4d1c2cab7749496d6cb8adff'
+ 'c70f85fe39eb601f25b595299c688bfd')
+
+package() {
+ install -dm755 "$pkgdir/usr/share/fonts/TTF"
+
+ install -m644 "$srcdir/cavafy-script-1.1/OpenType-TT/CavafyScriptTT.ttf" \
+ "$pkgdir/usr/share/fonts/TTF/CavafyScriptTT.ttf"
+
+ install -Dm644 legalcode.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+post_install () {
+ fontconfig
+}