summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDorianXGH2020-11-01 20:08:20 +0100
committerDorianXGH2020-11-01 20:08:20 +0100
commit94190da5e8aa5b1fb1c6b6f25d4329cd11d2b4fb (patch)
treef41644e732df507e9e13cf8a14378d14513e48db /PKGBUILD
parentdc45b8f6107a50e9dd613872cd45e52ea214ba78 (diff)
downloadaur-94190da5e8aa5b1fb1c6b6f25d4329cd11d2b4fb.tar.gz
added correct version numbering
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83195b1e82f1..758c00d88dae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Dorian Bourgeoisat <dorian dot bourgeoisat at icloud dot com>
pkgname=ttf-comic-mono-git
-pkgver=1
+pkgver=r21.03b5ad8
pkgrel=1
pkgdesc="like the famous font but monospace and with adjusted metric"
license=('MIT')
@@ -11,6 +11,11 @@ provides=("comic-mono")
source=("git+https://github.com/dtinth/comic-mono-font.git")
md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/comic-mono-font"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
package() {
cd "$srcdir/comic-mono-font"
install -d "$pkgdir/usr/share/fonts/TTF"