summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMa Jiehong2015-06-09 22:27:42 +0200
committerMa Jiehong2015-06-09 22:27:42 +0200
commit71de74a9443c1373fb38138b3e7980b47b699b08 (patch)
tree5104ae5be4db6a515fe31a8f1cb0f290e9c11157 /PKGBUILD
downloadaur-71de74a9443c1373fb38138b3e7980b47b699b08.tar.gz
Import cwtex-q-fonts to AUR 4 (and add ttf to its name)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4dae130d32ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ma Jiehong <majiehong.com/pages/contact.html>
+pkgname=ttf-cwtex-q-fonts
+pkgver=0.4
+pkgrel=2
+pkgdesc="Set of five Chinese truetype fonts derived from cwTeX"
+arch=('i686' 'x86_64')
+url="https://github.com/l10n-tw/cwtex-q-fonts"
+license=('GPL2')
+depends=('fontconfig' 'xorg-font-utils')
+conflicts=()
+install=ttf.install
+source=("https://github.com/l10n-tw/cwtex-q-fonts-TTFs/archive/v$pkgver.tar.gz")
+sha512sums=('02286502bf060a53ac925ab1b7ef52cbdc5f5bd83fab045a18a774656804082fd2cf95b93318efdfb9596110adc4c6d24fec3bbdd1446c8582172d9b26ba6646')
+
+build() {
+ echo
+}
+
+package() {
+ cd "$srcdir/cwtex-q-fonts-TTFs-$pkgver/ttf"
+ install -Dm644 cwTeXQFangsong-Medium.ttf "$pkgdir/usr/share/fonts/cwttf/cwTeXQFangsong-Medium.ttf"
+ install -Dm644 cwTeXQHei-Bold.ttf "$pkgdir/usr/share/fonts/cwttf/cwTeXQHei-Bold.ttf"
+ install -Dm644 cwTeXQKai-Medium.ttf "$pkgdir/usr/share/fonts/cwttf/cwTeXQKai-Medium.ttf"
+ install -Dm644 cwTeXQMing-Medium.ttf "$pkgdir/usr/share/fonts/cwttf/cwTeXQMing-Medium.ttf"
+ install -Dm644 cwTeXQYuan-Medium.ttf "$pkgdir/usr/share/fonts/cwttf/cwTeXQYuan-Medium.ttf"
+}