summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathon Fernyhough2017-07-30 13:13:15 +0100
committerJonathon Fernyhough2017-07-30 13:13:15 +0100
commit7119e8943e946e4de86ef2dab07432ee51603268 (patch)
tree151c6760c84c8e551178f50bde7bfe8214b31747 /PKGBUILD
parentab06632e6ab5d16a1c51b8409416f1bde3cb9dd1 (diff)
downloadaur-7119e8943e946e4de86ef2dab07432ee51603268.tar.gz
Remove unnecessary prepare(). Install to TTF directory.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 6 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ee7e28f95f22..c89287f3d3b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,22 @@
pkgname=ttf-fritz
_pkgname=fritz
pkgver=20150207
-pkgrel=1
+pkgrel=2
pkgdesc="Fritz TTF typeface"
arch=(any)
url="http://www.webpagefonts.com/"
license=(custom)
-source=("http://www.webpagepublicity.com/free-fonts/f/Fritz%20Regular.ttf"
- "http://www.webpagepublicity.com/free-fonts/f/Fritz%20Bold.ttf"
- "http://www.webpagepublicity.com/free-fonts/f/Fritz-Quad.ttf")
+source=("Fritz-Regular.ttf::http://www.webpagepublicity.com/free-fonts/f/Fritz%20Regular.ttf"
+ "Fritz-Bold.ttf::http://www.webpagepublicity.com/free-fonts/f/Fritz%20Bold.ttf"
+ "Fritz-Quad.ttf::http://www.webpagepublicity.com/free-fonts/f/Fritz-Quad.ttf")
sha256sums=('6eee8ff4f43262be46e2e44928ce23e54716ab8ec7c8ed3458f193a40334ede1'
'8f001c0e2db4f441ea8af55f9c54e2d4386fc8ea758014cd91cebea651aa7cc0'
'd89f7dec62cef1cb9fa85fb8013afc5aa150d554cf48a1fe2e39938ee794750c')
-prepare() {
- cd "${srcdir}"
- mkdir out
- msg2 "Renaming files..."
- for font in *ttf; do
- mv -v "${font}" out/"$(echo "${font}" | sed -e 's/%20/-/g' - )"
- done
- mv out/* ./
- rmdir out
-}
-
package() {
cd "${srcdir}"
- mkdir -p "${pkgdir}"/usr/share/fonts/${_pkgname}
- install -m644 ./*.ttf "${pkgdir}"/usr/share/fonts/${_pkgname}
+ mkdir -p "${pkgdir}"/usr/share/fonts/TTF/${_pkgname}
+ install -m644 ./*.ttf "${pkgdir}"/usr/share/fonts/TTF/${_pkgname}
# TODO find license
# install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE