summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Crowd2015-07-25 20:55:56 +0200
committerAndy Crowd2015-07-25 20:55:56 +0200
commit6941c1f9313c117aacfae13f79d229e61561e522 (patch)
tree832e1714a5c51ab878363599f58587e2a45be7bb /PKGBUILD
downloadaur-6941c1f9313c117aacfae13f79d229e61561e522.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90facfa7cc8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+pkgname=ttf-gujrati-fonts
+pkgver=0.0
+pkgrel=0
+pkgdesc="Gujrati Fonts"
+arch=(any)
+depends=(fontconfig xorg-font-utils)
+url="http://gujarati.indiatyping.com"
+
+
+
+source=(
+"http://gujarati.indiatyping.com/images/downloadfonts/Gujrati/Avantika.zip"
+"http://gujarati.indiatyping.com/images/downloadfonts/Gujrati/Gopika.zip"
+"http://gujarati.indiatyping.com/images/downloadfonts/Gujrati/Shree768.zip"
+)
+md5sums=(
+"31812c559691117d0d67da104bb8a16e"
+"07e02608f86c58adbe4faca233ab6e31"
+"db771843a551dea704ebf15b71341c78"
+)
+
+
+package() {
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -m644 "$srcdir/Avantika.ttf" "$pkgdir/usr/share/fonts/TTF/"
+ install -m644 "$srcdir/Gopika.ttf" "$pkgdir/usr/share/fonts/TTF/"
+ install -m644 "$srcdir/Shree768.ttf" "$pkgdir/usr/share/fonts/TTF/"
+
+}
+
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache >/dev/null -f
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo done
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}