summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Crowd2015-07-25 20:57:11 +0200
committerAndy Crowd2015-07-25 20:57:11 +0200
commita5c6867a0e2d0dd67dcd49908923d50f61251347 (patch)
tree1bab941b610f19f4c1c876a634785676af005298 /PKGBUILD
downloadaur-a5c6867a0e2d0dd67dcd49908923d50f61251347.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13dfa677a8a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=ttf-gurmukhi_punjabi
+pkgver=0.0
+pkgrel=0
+pkgdesc="Gurmukhi/ Punjabi - 252 fonts"
+arch=(any)
+depends=(fontconfig xorg-font-utils)
+url="http://www.billie.grosse.is-a-geek.com"
+
+source=(
+"http://www.billie.grosse.is-a-geek.com/res/local/allbillie.tar.bz2"
+)
+
+md5sums=(
+"15b7f0ad720eeb0e62da344978305229"
+)
+
+package() {
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -m644 "$srcdir/"*.ttf "$pkgdir/usr/share/fonts/TTF/"
+}
+
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache >/dev/null -f
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo done
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}