summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrett Cornwall2023-10-19 19:35:01 -0700
committerBrett Cornwall2023-10-19 19:35:01 -0700
commit23719ca2dff09330ffa5f068af982eb52eb9d183 (patch)
treec4c5d0cc2cf8c52d5c68aa785e75eabc80c11d52 /PKGBUILD
downloadaur-23719ca2dff09330ffa5f068af982eb52eb9d183.tar.gz
Demote to the AUR
Upstream doesn't distribute .ttf files any more.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1317c1885a0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Brett Cornwall <ainola@archlinux.org>
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=ttf-ionicons
+# TODO: Newer versions of ionicons don't come with any .ttf; They only
+# distribute SVGs.
+pkgver=4.2.0
+epoch=1
+pkgrel=1
+pkgdesc='Font from the Ionic mobile framework'
+arch=('any')
+license=('MIT')
+url='https://ionicons.com/'
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ionic-team/ionicons/archive/v${pkgver/_/-}.tar.gz")
+sha256sums=('33d85e4f970edea75dbe11626075834a5142c5cd817f61c9b505270addb49414')
+
+package() {
+ cd "ionicons-${pkgver/_/-}"
+ install -Dm644 docs/fonts/ionicons.ttf -t "$pkgdir/usr/share/fonts/TTF/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}