summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Kluger2018-10-10 16:50:48 -0400
committerAndy Kluger2018-10-10 16:50:48 -0400
commit12ff9471f8ccd48c8c5735089c237e8560f19a09 (patch)
tree3a983a053a57fc8f76adb8d3d0662c29e1596e7e /PKGBUILD
parent5c9e3a175ef24cb0858b3beee92a9eb55fec59ea (diff)
downloadaur-12ff9471f8ccd48c8c5735089c237e8560f19a09.tar.gz
hacks to ensure a shallow checkout (a few mb vs nearly 1gb), and change versioning scheme to 'date.short-hash'
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f163a33f7ba..9490ba155305 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andy Kluger <AndyKluger@gmail.com>
# Contributor: Markus Weimar <mail@markusweimar.de>
pkgname=ttf-iosevka-git
-pkgver=r1137.ffc50ab3
+pkgver=2018.10.05T06.46.02Z.68b55c13
pkgrel=1
pkgdesc='A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.'
arch=('any')
@@ -11,12 +11,18 @@ makedepends=('git' 'nodejs' 'npm' 'ttfautohint' 'otfcc')
depends=('fontconfig' 'xorg-font-utils')
conflicts=('ttf-iosevka')
provides=('ttf-iosevka')
-source=("git+https://github.com/be5invis/Iosevka")
-md5sums=('SKIP')
+source=()
+md5sums=()
pkgver() {
- cd "Iosevka"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ commits=$(curl --silent https://api.github.com/repos/be5invis/Iosevka/commits)
+ tstamp=$(printf "$commits" | grep '\s*"date":' | head -1 | cut -d '"' -f 4 | sed -E 's/-|:/./g')
+ short_sha=$(printf "$commits" | grep '\s*"sha":' | head -1 | cut -d '"' -f 4 | cut -c -8)
+ printf "$tstamp.$short_sha"
+}
+
+prepare() {
+ git clone --depth=1 https://github.com/be5invis/Iosevka
}
build() {