summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Kluger2017-02-23 16:12:03 -0500
committerAndy Kluger2017-02-23 16:12:03 -0500
commit23e8c07130a8cc2d7ff239e5f80bff69d77e7698 (patch)
tree64f9e19c5f19885bd73e4ff0f417d4499505900d /PKGBUILD
downloadaur-23e8c07130a8cc2d7ff239e5f80bff69d77e7698.tar.gz
nothing fancy, just compile from git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98f34ebc2178
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Andy Kluger <AndyKluger@gmail.com>
+# Contributor: Markus Weimar <mail@markusweimar.de>
+pkgname=ttf-iosevka-git
+pkgver=r906.695db24
+pkgrel=1
+pkgdesc='A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.'
+arch=('any')
+url='https://be5invis.github.io/Iosevka/'
+license=('custom:OFL')
+makedepends=('git' 'nodejs' 'npm' 'ttfautohint' 'otfcc')
+depends=('fontconfig' 'xorg-font-utils')
+conflicts=('ttf-iosevka-hooky' 'ttf-iosevka-zshaped' 'ttf-iosevka' 'ttf-iosevka-custom-git')
+provides=('ttf-iosevka')
+source=("git+https://github.com/be5invis/Iosevka")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "Iosevka"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd Iosevka
+ npm install
+ make
+}
+
+package() {
+ install -d "${pkgdir}/usr/share/fonts/TTF"
+ install -m644 Iosevka/dist/*/*.ttf "${pkgdir}/usr/share/fonts/TTF/"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 Iosevka/LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/"
+}