summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Kluger2020-03-06 01:15:27 -0500
committerAndy Kluger2020-03-06 01:18:23 -0500
commitb74395af41532eecd093efb4476c3667b82a3686 (patch)
tree78f20fea1de3a3b15d6b2205493e2aed268ee453 /PKGBUILD
parentf078ef77b0629dcfabb6c661ae2d5d2576776ba1 (diff)
downloadaur-b74395af41532eecd093efb4476c3667b82a3686.tar.gz
include disabled G-patch; update node modules; use new names in pptoml; remove slab plans; seems to build ok despite gyp error, see open issue on iosevka's tracker
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d682bb470bd1..4c18963e2831 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,12 +12,14 @@ depends=('fontconfig' 'xorg-font-utils')
conflicts=()
provides=()
source=(
- "git+https://github.com/be5invis/Iosevka"
- "private-build-plans.toml.example"
+ 'git+https://github.com/be5invis/Iosevka'
+ 'private-build-plans.toml.example'
+ 'toothless-G.patch'
)
sha256sums=(
'SKIP'
- '930cc4b63f9076e6cb40599ef7d51fc7fdab2eaac6a76bf344eb2d79ee4a950e'
+ '6004e471b9188445cc8c6c371384a42bedeecb1935765db1d82b4677b1342bc2'
+ '56d1d97b421ab462d71875ecadf57d65ee45fe26edee50922ae9ae96350cff52'
)
pkgver() {
@@ -31,13 +33,22 @@ prepare() {
cp "$buildplans" Iosevka/
else
echo ">>> $buildplans not found, using private-build-plans.toml.example"
- cp ../private-build-plans.toml.example Iosevka/
+ cp private-build-plans.toml.example Iosevka/private-build-plans.toml
fi
+
+ cd Iosevka
+
+ # patch -p1 < ../toothless-G.patch
+
+ # Uncomment the above line to get back the smoother capital G,
+ # as seen in this image (look for "LIGHT"):
+ # https://raw.githubusercontent.com/be5invis/Iosevka/47023ab4058987f58844f6308d8175e735106b8a/images/preview-all.png
}
build() {
cd Iosevka
npm install
+ npm update
npm run build -- ttf::iosevka-term-custom
}