summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Kluger2020-11-09 22:39:08 -0500
committerAndy Kluger2020-11-09 22:39:08 -0500
commitd71309d161a5535c2665976bba36e3fc92379fe4 (patch)
tree579569983a207107c04005d5c007e59e7a957f0d /PKGBUILD
parent00cbb8b4e1d67b66b8557aed13704561f549b647 (diff)
downloadaur-d71309d161a5535c2665976bba36e3fc92379fe4.tar.gz
new config format for iosevka v4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca6823a639f1..1def80d775fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Andy Kluger <AndyKluger@gmail.com>
+# Maintainer: Andy Kluger <https://t.me/andykluger>
# Contributor: Markus Weimar <mail@markusweimar.de>
-pkgname=ttf-iosevka-term-custom-git
-pkgver=r2050.075dd6e4
+_pkgname=ttf-iosevka-term-custom
+pkgname=${_pkgname}-git
+pkgver=r2089.115f5b19
pkgrel=1
pkgdesc='A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.'
arch=('any')
url='https://be5invis.github.io/Iosevka/'
license=('custom:OFL')
-makedepends=('git' 'nodejs' 'npm' 'ttfautohint')
+makedepends=('git' 'nodejs>=12.16.0' 'npm' 'ttfautohint')
depends=()
-conflicts=('ttf-iosevka-term-custom')
-provides=('ttf-iosevka-term-custom')
+conflicts=(${_pkgname})
+provides=(${_pkgname})
replaces=('ttf-iosevka-termlig-custom-git')
source=(
'git+https://github.com/be5invis/Iosevka'
@@ -18,7 +19,7 @@ source=(
)
sha256sums=(
'SKIP'
- 'af64725b342f402bedf6338343a6983f7b5c36a0a6ac2ecae1d492613956f9eb'
+ '132530ab6290715e1b31b7743c13e8e06af2df189739bf5ef29d3558f615a154'
)
pkgver() {
@@ -40,7 +41,7 @@ build() {
cd Iosevka
npm install
npm update
- npm run build -- ttf::iosevka-term-custom
+ npm run build -- ttf::${_pkgname#*-}
}
package() {