summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLightDot2018-02-22 16:28:52 +0100
committerLightDot2018-02-22 16:28:52 +0100
commitdf145ac35c525d1340dce1478d75ee09c29b2151 (patch)
tree96c9ccc4772974e2daae9b969190d9ea86be5edf /PKGBUILD
parent001c15dbcf015900ded9a1ff10f21e13ab89db0f (diff)
downloadaur-df145ac35c525d1340dce1478d75ee09c29b2151.tar.gz
PKGBUILD cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 922c51eec561..62f3d13ca7c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
-# Maintainer: samæ <samæ at marvid dot fr>
+# Maintainer: LightDot <lightdot -a-t- g m a i l>
+# Contributor: samæ <samæ at marvid dot fr>
_fnt_name=junction
pkgname=ttf-${_fnt_name}
pkgver=20160215
-pkgrel=1
+pkgrel=2
pkgdesc="Junction is a a humanist sans-serif, and the first open-source type project started by The League of Moveable Type."
arch=('any')
url="http://theleagueofmoveabletype.com/${_fnt_name}"
license=('custom:OFL')
groups=('lmt-fonts')
-depends=('fontconfig' 'xorg-font-utils')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
conflicts=('otf-junction')
-source=("https://github.com/theleagueof/${_fnt_name}/archive/master.zip")
-install=${pkgname}.install
+source=("$pkgname-$pkgver.zip::https://github.com/theleagueof/${_fnt_name}/archive/master.zip")
md5sums=('e35636a6a9075db4f1bc09df69b8d0d3')
package() {
@@ -20,10 +20,9 @@ package() {
install -Dm644 ${srcdir}/${_fnt_name}-master/Junction-light.otf ${pkgdir}/usr/share/fonts/OTF/JunctionLight.otf
install -Dm644 ${srcdir}/${_fnt_name}-master/Junction-regular.otf ${pkgdir}/usr/share/fonts/OTF/JunctionRegular.otf
- install -Dm644 ${srcdir}/${_fnt_name}-master/webfonts/junction-bold.ttf ${pkgdir}/usr/share/fonts/OTF/JunctionBold.ttf
- install -Dm644 ${srcdir}/${_fnt_name}-master/webfonts/junction-light.ttf ${pkgdir}/usr/share/fonts/OTF/JunctionLight.ttf
- install -Dm644 ${srcdir}/${_fnt_name}-master/webfonts/junction-regular.ttf ${pkgdir}/usr/share/fonts/OTF/JunctionRegular.ttf
+ install -Dm644 ${srcdir}/${_fnt_name}-master/webfonts/junction-bold.ttf ${pkgdir}/usr/share/fonts/TTF/JunctionBold.ttf
+ install -Dm644 ${srcdir}/${_fnt_name}-master/webfonts/junction-light.ttf ${pkgdir}/usr/share/fonts/TTF/JunctionLight.ttf
+ install -Dm644 ${srcdir}/${_fnt_name}-master/webfonts/junction-regular.ttf ${pkgdir}/usr/share/fonts/TTF/JunctionRegular.ttf
install -Dm644 ${srcdir}/${_fnt_name}-master/Open\ Font\ License.markdown ${pkgdir}/usr/share/licenses/${pkgname}/OFL.txt
}
-