summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraoisensi2021-01-16 16:24:52 +0900
committeraoisensi2021-01-16 16:24:52 +0900
commit278778acd51e035c76307deb48a27b3025c248fa (patch)
treee2046d9427bfec9d2b13719954e3ffd4373d80e8 /PKGBUILD
downloadaur-ttf-killgothic-u.tar.gz
first
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..beb0b6a2436e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: aoisensi <me@aoisensi.info>
+
+pkgname=ttf-killgothic-u
+pkgver=0.99b
+pkgrel=1
+pkgdesc='A free ttf font with the theme of the anime "Kill Me Baby".'
+arch=('any')
+url='http://www.getsuren.com/en/killgoU.html'
+license=('custom')
+source=('GN-KillGothic_U.zip::http://getsuren.com/download/download.cgi?name=GN-KillGothic_U.zip')
+sha256sums=('e0ec9c9a8058e928b08bf8df7ddd6fb238db05e3f63d8c44493e246725a48177')
+
+build() {
+ sed -n "/・It's not indispensable/,/using these fonts./p" readme_en.txt > LICENSE
+}
+
+package() {
+ install -dm 755 "${pkgdir}/usr/share/fonts/TTF"
+ install -m 644 GN-KillGothic-U-KanaNA.ttf "${pkgdir}/usr/share/fonts/TTF/GN-KillGothic-U-KanaNA.ttf"
+ install -m 644 GN-KillGothic-U-KanaNB.ttf "${pkgdir}/usr/share/fonts/TTF/GN-KillGothic-U-KanaNB.ttf"
+ install -m 644 GN-KillGothic-U-KanaO.ttf "${pkgdir}/usr/share/fonts/TTF/GN-KillGothic-U-KanaO.ttf"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+} \ No newline at end of file