summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Crowd2015-07-25 20:57:57 +0200
committerAndy Crowd2015-07-25 20:57:57 +0200
commit1ef670bc8a787fa5f0a2bfd24afaf00ecee43546 (patch)
tree938a28c6daa0e887b3ce273826e792fcca8c6632 /PKGBUILD
downloadaur-ttf-lao.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d2370905cc2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Andy Crowd andy_crowd@ainsdata.se
+pkgname=ttf-lao
+pkgver=0.0
+pkgrel=20060226
+pkgdesc="Lao TTF fonts"
+arch=(any)
+depends=(fontconfig xorg-font-utils)
+url="http://prdownloads.sourceforge.net/laofoss/Phetsarath_OT.zip"
+license=('GPL-2.1 or late')
+source=(http://prdownloads.sourceforge.net/laofoss/Phetsarath_OT.zip
+)
+
+md5sums=(2a8d37d7ea2d937b101226edda11200b)
+
+package() {
+install -d "$pkgdir/usr/share/fonts/TTF"
+install -m644 "Phetsarath_OT.ttf" "$pkgdir/usr/share/fonts/TTF/"
+
+}
+
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache >/dev/null -f
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo done
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+