summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2021-07-08 12:04:54 +0300
committerCaleb Maclennan2021-07-08 12:04:54 +0300
commit63839add640aea53a5515d57f64bdb736c1d6b64 (patch)
tree1bc58a8fa8aad22e019d2a8e8ca466aefd653b5e /PKGBUILD
parente28acfa5e541033e8919f33f1f500c340bd2d58a (diff)
downloadaur-63839add640aea53a5515d57f64bdb736c1d6b64.tar.gz
upgpkg: ttf-nishiki-teki 3.81x-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 10 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 34c225bd99a5..1b978b5f12f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,20 @@
-# Maintainer: George Rawlinson <george@rawlinson.net.nz>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: George Rawlinson <george@rawlinson.net.nz>
# Contributor: mock
pkgname=ttf-nishiki-teki
-pkgver=3.65s
+pkgver=3.81x
pkgrel=1
pkgdesc='Unicode-based font inspired by a free shell of Ukagaka called “Nishiki”'
arch=('any')
-url='http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki.htm'
+url='https://umihotaru.work'
license=('custom')
-source=("$pkgname.zip::http://hwm3.gyao.ne.jp/shiroi-niwatori/nishiki-teki.zip"
- "LICENSE")
-sha512sums=('SKIP'
- 'f6138f41a7eade900bcda1a5be608cbb4a8205ce53c6d175d6ae13693ff34b8e2cdc42f9dd4ae49b7285a5f09c1fb4f077ad872361abb8303c1589acf5958436')
-
-pkgver() {
- cd nishiki-teki_*
- grep -Eo 'Version [[:digit:]]\.[[:digit:]]*[[:alpha:]]?' nishiki-teki.htm | head -n 1 | sed 's/Version //'
-}
+source=("$pkgname-$pkgver.zip::http://umihotaru.fool.jp/nishiki-teki.zip"
+ 'LICENSE')
+sha256sums=('853d06dc3c05cb3dabdf6e46455d20d35e3ff7992d0149f6063d9bb36d788ec6'
+ 'a60b2362ac0885bc4d7b013ccbbe38e2aeded839b3d88993add246d9076f72ad')
package() {
- cd nishiki-teki_*
-
- # install font
- install -Dm644 nishiki-teki.ttf "$pkgdir/usr/share/fonts/TTF/nishiki-teki.ttf"
-
- # install docs
- install -Dm644 nishiki-teki.htm "$pkgdir/usr/share/doc/$pkgname/nishiki-teki.htm"
- install -Dm644 img/banner_nishiki-teki.png "$pkgdir/usr/share/doc/$pkgname/img/banner_nishiki-teki.png"
- install -Dm644 img/nishiki.css "$pkgdir/usr/share/doc/$pkgname/img/nishiki.css"
-
- # install license
- install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" nishiki-teki.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" "LICENSE"
}