summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author0tkl2023-07-29 14:37:50 +0800
committer0tkl2023-07-29 14:37:50 +0800
commit0ac539a0834ed47d711f2547d1978ac48a312012 (patch)
tree5d544023f8b45c429f44efb90f5911bdeebe5cf2 /PKGBUILD
parentf20f395a36d28f28a78a9f70ec6b17ff0ec25759 (diff)
downloadaur-0ac539a0834ed47d711f2547d1978ac48a312012.tar.gz
format PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 19 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e941bbbe7de..400cb45baac0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
+# Maintainer: Takina Lina <0tkl.zhaoqing@gmail.com>
+
pkgname=ttf-plangothic
pkgver=0.8.5744
-pkgrel=1
+pkgrel=2
pkgdesc='遍黑体项目(Plangothic Project)'
-arch=('any')
+arch=(any)
url='https://github.com/Fitzgerald-Porthmouth-Koenigsegg/Plangothic-Project'
-license=('SIL Open Font License')
-depends=('fontconfig')
-source=("https://github.com/Fitzgerald-Porthmouth-Koenigsegg/Plangothic-Project/releases/download/V$pkgver/PlangothicP1-Regular.fallback.ttf"
-"https://github.com/Fitzgerald-Porthmouth-Koenigsegg/Plangothic-Project/releases/download/V$pkgver/PlangothicP2-Regular.ttf"
-"https://github.com/Fitzgerald-Porthmouth-Koenigsegg/Plangothic-Project/raw/main/LICENSE")
-md5sums=('df54afe4c7b7ad041e9810e07295ee06'
- 'b14651028f8902296cd290e16b1bdbf6'
- '76f275fef4c3e68344037d125b1cbe10')
+license=(OFL)
+depends=(fontconfig)
+source=(
+ "https://github.com/Fitzgerald-Porthmouth-Koenigsegg/Plangothic-Project/releases/download/V$pkgver/PlangothicP1-Regular.fallback.ttf"
+ "https://github.com/Fitzgerald-Porthmouth-Koenigsegg/Plangothic-Project/releases/download/V$pkgver/PlangothicP2-Regular.ttf"
+ "https://github.com/Fitzgerald-Porthmouth-Koenigsegg/Plangothic-Project/raw/main/LICENSE"
+)
+md5sums=(
+ 'df54afe4c7b7ad041e9810e07295ee06'
+ 'b14651028f8902296cd290e16b1bdbf6'
+ '76f275fef4c3e68344037d125b1cbe10'
+)
package() {
- install -Dm644 "$srcdir/PlangothicP1-Regular.fallback.ttf" "$pkgdir/usr/share/fonts/plangothic/PlangothicP1-Regular.ttf"
- install -Dm644 "$srcdir/PlangothicP2-Regular.ttf" "$pkgdir/usr/share/fonts/plangothic/PlangothicP2-Regular.ttf"
- install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/PlangothicP1-Regular.fallback.ttf" "$pkgdir/usr/share/fonts/plangothic/PlangothicP1-Regular.ttf"
+ install -Dm644 "$srcdir/PlangothicP2-Regular.ttf" "$pkgdir/usr/share/fonts/plangothic/PlangothicP2-Regular.ttf"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}