summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-15 12:24:43 +0300
committerCaleb Maclennan2020-02-15 12:24:43 +0300
commit54a9b0ebb53e97ff2bbc622094bfd69947ac2262 (patch)
tree80b08a1dd4a218b99f9ce4ed0dba9df98ca57a86 /PKGBUILD
downloadaur-54a9b0ebb53e97ff2bbc622094bfd69947ac2262.tar.gz
Initial independent packaging, previously in ttf-sil-fonts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f77e978eae85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_pkgname=apparatus
+pkgname=ttf-sil-$_pkgname
+_fname=ApparatusSIL
+_pname=AppSIL
+pkgver=1.0
+pkgrel=1
+pkgdesc='Symbols used for Biblical text apparatus'
+arch=('any')
+url="https://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&id=$_fname"
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-font-utils')
+source=("$_fname-$pkgver.zip::https://scripts.sil.org/cms/scripts/render_download.php?format=file&media_id=$_pname$pkgver.zip&filename=$_fname.zip")
+sha256sums=('0d8e3143b9c46c97916ab2cf85ae2187fe33b9b40859567a5524266dd58581bc')
+
+package() {
+ cd "Apparatus SIL"
+ find -type f -iname "$_pname*.ttf" -execdir \
+ install -Dm644 {} -t "$pkgdir/usr/share/fonts/TTF" \;
+ install -Dm644 OFL.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+}