summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrLi2021-07-27 22:57:38 +0800
committerBrLi2021-07-27 22:57:38 +0800
commit0d1ba0c4b67912790bb93141bc1ffce5768028d4 (patch)
treeac7270728ff90606040204371a6a0c1300e1ffd2 /PKGBUILD
parent5cb86671c16b52b3d9f851e59993d18583bcdbb8 (diff)
downloadaur-0d1ba0c4b67912790bb93141bc1ffce5768028d4.tar.gz
directly use upstream link, notes on fallback git repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 179650a283f2..74785925982d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,31 @@
# Maintainer: Ma Jiehong <email at majiehong.com>
pkgname=ttf-tw
epoch=1
-pkgver=20201114
+pkgver=20210727
pkgrel=1
pkgdesc="Set of KAI and SONG fonts from the Ministry of Education of Taiwan. These fonts follow all the official recommendations and their shapes are calligraphically correct. (TTF/UTF-8)"
arch=('any')
url="http://www.moe.gov.tw/"
license=('CC-BY-ND 3.0')
-depends=()
-makedepends=('git')
-conflicts=()
-source=(git+https://github.com/Jiehong/TW-fonts.git)
-sha512sums=('SKIP')
+# backup source: git+https://github.com/Jiehong/TW-fonts.git
+# makedepends=(git)
+source=(https://language.moe.gov.tw/001/Upload/Files/site_content/M0001/edukai-4.0.zip
+ https://language.moe.gov.tw/001/Upload/Files/site_content/M0001/eduSong_Unicode.zip
+ https://language.moe.gov.tw/001/Upload/Files/site_content/M0001/edukai.pdf
+ https://language.moe.gov.tw/001/Upload/Files/site_content/M0001/edusun.pdf)
+sha512sums=('fdb346310b12357128f50a0ef93571e1fd4a77dd9289c3efb706787c327d4c5ac7917112de6fcad6dd22213740b10aa5aef2c021c0c0cc50d14bc6132b735d18'
+ '2af97c4456f829d7da73d90ebdd194db480262cc36250e8e51bef581afeeead10493c00f1f06d78f0bf54cae3bc1439b251b2a97e0601e043cd0795a09d5ce67'
+ '069266d54c828af59eaec425201a09affd71c5633233a14040f395d975f97f08fbab62b7d062436aed7e725c281705e08be2ee282d0b202d4ab7ad392a95e8f9'
+ '2fb45aa7818652daf39fab975efe2f4ca3b7bd95b7fde7b0a76845e40ef75d37a8f3a15ce00f159d8ed94bdd0428b85c83b3bcc7c0e9b88c00b0bf72c05a84ad')
-pkgver()
-{
- cd "$srcdir/TW-fonts"
- git show --no-patch --date=short --format=format:%cd | tr -d -
+pkgver() {
+ date +%4Y%m%d
}
-package()
-{
+package() {
cd "$srcdir"
- install -Dm644 TW-fonts/edukai-4.0.ttf "$pkgdir/usr/share/fonts/TTF/edukai-4.0.ttf"
- install -Dm644 TW-fonts/eduSong_Unicode.ttf "$pkgdir/usr/share/fonts/TTF/eduSong_Unicode.ttf"
+ install -Dm644 edukai-4.0.ttf "${pkgdir}/usr/share/fonts/TTF/edukai-4.0.ttf"
+ install -Dm644 eduSong_Unicode.ttf "${pkgdir}/usr/share/fonts/TTF/eduSong_Unicode.ttf"
+ install -Dm644 edukai.pdf "${pkgdir}/usr/share/licenses/${pkgname}/edukai.pdf"
+ install -Dm644 edusun.pdf "${pkgdir}/usr/share/licenses/${pkgname}/edukai.edusun.pdf"
}