summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrLi2016-05-25 00:51:16 +0800
committerBrLi2016-05-25 00:51:16 +0800
commitf71857c277a3271082e9e9bd190f106099dda7dc (patch)
tree81cb45fc1a5ecc517505ca1005f31249f90c1401 /PKGBUILD
downloadaur-f71857c277a3271082e9e9bd190f106099dda7dc.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9ef14e9c776
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: BrLi <brli@chakraos.org>
+
+pkgname=ttf-twcns-fonts
+pkgdesc=('Chinese TrueType fonts by Taiwan government, support CNS11643 standard, including Kai and Sung fontface')
+pkgver=98.1
+pkgrel=1
+arch=any
+depends=(freetype2 fontconfig)
+makedepends=(libarchive)
+source=('AIDB_soft-100-1.linux.sh::http://www.cns11643.gov.tw/AIDB/file.do?path=download/個人電腦造字處理工具`1q`Unicode平台`1q`全字庫軟體包(Linux版)/name/AIDB_soft-100-1.linux.sh'
+ 'LICENSE')
+sha1sums=('36a7489c9bb1cb2cb7e09951617c7719ac83786b'
+ 'f7bd9f63e62492e0be4c7ef44916f6d5e0efbcf2')
+
+prepare() {
+ sh AIDB_soft-100-1.linux.sh || true # We don't have yum
+ mkdir -p twcns-fonts && cd twcns-fonts
+ bsdtar -xf ../twcns-fonts-98.1-1.noarch.rpm
+}
+
+package() {
+ for dir in usr etc; do
+ cp -rv ${srcdir}/twcns-fonts/${dir} ${pkgdir}/${dir}
+ done
+ install -Dm644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}