summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrLi2019-06-25 22:28:30 +0800
committerBrLi2019-06-25 22:28:30 +0800
commitf781fb52e0242c9f0490d8f6f55c3dd5ae779c62 (patch)
treea386b5c0c63fe5e4c3eabc1eec297c40f13e6387 /PKGBUILD
parent3aee7518d7009131454a4f324e96e96a1ed3feaa (diff)
downloadaur-f781fb52e0242c9f0490d8f6f55c3dd5ae779c62.tar.gz
move the rename action to prepare()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43c8b1630c45..6bad405c3658 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ttf-webhostinghub-glyphs
pkgver=1.0
-pkgrel=6
+pkgrel=7
pkgdesc='WebHostingHub Glyphs icon font by webhostinghub.com'
arch=('any')
url='https://www.webhostinghub.com/glyphs/'
@@ -14,9 +14,12 @@ source=('https://www.webhostinghub.com/glyphs/resources/whhg-font.zip'
sha256sums=('c299b4c0fc02a2cc4b8efe8ddeb5cc9d13fcd5f86bcb83d4ff35326a82f9db97'
'e26a38873f73098c1c51420bcffc064c78d7f63fe2f0b009be4aea91ac7c3dab')
+prepare() {
+ cp -rv $srcdir/whhg-font/font/webhostinghub{-,}glyphs.ttf
+ fontforge -script ./rename.pe $srcdir/whhg-font/font/webhostinghubglyphs.ttf
+}
+
package() {
- install -d $pkgdir/usr/share/fonts/TTF/
- install -m644 $srcdir/whhg-font/font/webhostinghub-glyphs.ttf $pkgdir/usr/share/fonts/TTF/
- ./rename.pe whhg-font/font/webhostinghub-glyphs.ttf
- install -Dm644 $srcdir/whhg-font/font/webhostinghub-glyphs.ttf $pkgdir/usr/share/fonts/TTF/webhostinghubglyphs.ttf
+ install -Dm644 $srcdir/whhg-font/font/webhostinghub-glyphs.ttf $pkgdir/usr/share/fonts/TTF/webhostinghub-glyphs.ttf
+ install -Dm644 $srcdir/whhg-font/font/webhostinghubglyphs.ttf $pkgdir/usr/share/fonts/TTF/webhostinghubglyphs.ttf
}