summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2021-06-23 22:38:24 +0300
committerCaleb Maclennan2021-06-23 22:38:24 +0300
commit527eb2776826c03cea32607112237a21c0b098c6 (patch)
treee281c735fda5dfe19cdf0dfb9a9d7e0fba1043b2 /PKGBUILD
parentde806ed5249187f1310e8cad31a88a793257f5f0 (diff)
downloadaur-527eb2776826c03cea32607112237a21c0b098c6.tar.gz
Update for Savannah upstream URL change
Known-broken, but that's because upstream HEAD is broken. At least the parts I know need fixing are updated.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD82
1 files changed, 41 insertions, 41 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30a261e2ce09..585325e4268b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,63 +4,63 @@
pkgname=ttfautohint-git
pkgver=1.8.3.r16.g701aa67
-pkgrel=3
+pkgrel=4
pkgdesc='Provides automated hinting process for web fonts'
-arch=('i686' 'x86_64')
+arch=(x86_64 i686)
url="http://www.freetype.org/${pkgname%-git}"
-license=('GPL' 'custom')
-depends=('freetype2' 'harfbuzz' 'qt5-base')
-makedepends=('pandoc'
- 'inkscape'
- 'imagemagick'
- 'noto-fonts'
- # 'noto-fonts-alpha'
- 'texlive-core'
- 'xorg-xwininfo')
-provides=("${pkgname/%-git}")
-conflicts=("${provides[@]}")
-source=("git://repo.or.cz/${pkgname/-/.}"
- "git://git.sv.gnu.org/gnulib.git")
+license=(GPL custom)
+depends=(freetype2
+ harfbuzz
+ qt5-base)
+makedepends=(imagemagick
+ inkscape
+ noto-fonts
+ pandoc
+ texlive-core
+ xorg-xwininfo)
+conflicts=("${pkgname/%-git}")
+provides=("${pkgname/%-git}=$pkgver")
+source=("$pkgname::git://repo.or.cz/${pkgname/-/.}"
+ "gnulib-git::git+https://git.savannah.gnu.org/git/gnulib.git")
sha256sums=('SKIP'
'SKIP')
pkgver() {
- cd "${pkgname%-git}"
- git describe --tags --abbrev=7 --match="v*" HEAD |
- sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$pkgname"
+ git describe --tags --abbrev=7 --match="v*" HEAD |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare(){
- cd "${pkgname%-git}"
- git submodule init
- git config submodule.gnulib.url "$srcdir/gnulib"
- git submodule update
- echo "GNULIB_URL='$srcdir/gnulib'" > bootstrap.conf
- sed -i -e '400s/yes/no/' bootstrap
- ./bootstrap --force
+ cd "$pkgname"
+ git submodule init
+ git config submodule.gnulib.url "$srcdir/gnulib-git"
+ git submodule update
+ echo "GNULIB_URL='$srcdir/gnulib-git'" > bootstrap.conf
+ ./bootstrap --force
}
build() {
- cd "${pkgname%-git}"
- export QMAKE='/usr/bin/qmake'
- export MOC='/usr/bin/moc'
- export UIC='/usr/bin/uic'
- export RCC='/usr/bin/rcc'
- export TTFONTS='/usr/share/fonts/noto'
- ./configure \
- --prefix=/usr \
- --with-qt=/usr/lib/qt \
- --with-freetype-config="pkg-config freetype2"
- make
+ cd "$pkgname"
+ export QMAKE='/usr/bin/qmake'
+ export MOC='/usr/bin/moc'
+ export UIC='/usr/bin/uic'
+ export RCC='/usr/bin/rcc'
+ export TTFONTS='/usr/share/fonts/noto'
+ ./configure \
+ --prefix=/usr \
+ --with-qt=/usr/lib/qt \
+ --with-freetype-config="pkg-config freetype2"
+ make
}
check() {
- cd "${pkgname%-git}"
- make -k check
+ cd "$pkgname"
+ make -k check
}
package() {
- cd "${pkgname%-git}"
- make DESTDIR="$pkgdir" install
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" COPYING FTL.TXT
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" COPYING FTL.TXT
}