summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2018-08-14 21:19:11 +0200
committerChristopher Arndt2018-08-14 21:19:11 +0200
commit9342c8abe1a6d64f01c3dbc6e55914a79428cf70 (patch)
tree474e98c0db91b830ddd875cc01b3aee2eba1199e /PKGBUILD
parent6572181f115a1528334195619fb58386b0d148eb (diff)
downloadaur-9342c8abe1a6d64f01c3dbc6e55914a79428cf70.tar.gz
Build is incompatible with Python 3.7+, use Python 2 instead
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7654b2d377c..f50877df47d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_pkgname=ttl2c
pkgname="${_pkgname}-git"
pkgver=1.0.1.r5.b64e425
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Turtle to header conversion utility for LV2 Plugin developers "
arch=('i686' 'x86_64')
url="https://github.com/lvtk/ttl2c"
license=('GPL3')
depends=('boost-libs')
-makedepends=('python')
+makedepends=('python2')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
source=("${_pkgname}::git+https://github.com/lvtk/ttl2c.git")
@@ -29,14 +29,14 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- python waf configure --prefix=/usr
- python waf build
+ python2 waf configure --prefix=/usr
+ python2 waf build
}
package() {
cd "${srcdir}/${_pkgname}"
- python waf install --destdir="$pkgdir"
+ python2 waf install --destdir="$pkgdir"
}
# vim:set ts=2 sw=2 et: