summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Vikstrom2018-10-17 10:01:04 +0200
committerSimon Vikstrom2018-10-17 10:01:04 +0200
commit86baaf06a65362df9d1cca60e5fb2d1deca0a73d (patch)
tree259e899164eee09c806ad951a2a7c18b80aac843 /PKGBUILD
downloadaur-86baaf06a65362df9d1cca60e5fb2d1deca0a73d.tar.gz
Init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..827802068ef6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=ttyplot-git
+pkgver=r22.ac8c3c3
+pkgrel=1
+pkgdesc="a realtime plotting utility for terminal with data input from stdin"
+arch=('x86_64')
+license=('Apache 2.0')
+url="https://github.com/tenox7/ttyplot"
+source=('git+https://github.com/tenox7/ttyplot.git')
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd ttyplot
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $srcdir/ttyplot
+ make
+}
+
+package() {
+ install -D -m755 $srcdir/ttyplot/ttyplot $pkgdir/usr/bin/ttyplot
+}