summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaichi Shinozaki2016-03-14 21:16:53 +0900
committerDaichi Shinozaki2016-03-14 21:16:53 +0900
commit3886a2553b4aade774d207de9d86335b7628a9ca (patch)
treee1d20c37896a647e0fcfdc2d39e5f8bc73178d79 /PKGBUILD
downloadaur-3886a2553b4aade774d207de9d86335b7628a9ca.tar.gz
Initial import from https://github.com/XiaoxiaoPu/PKGBUILDs/blob/master/ttyrec.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1904bf24e9e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Xiaoxiao Pu <i@xiaoxiao.im>
+# Contributor: Daichi Shinozaki <dsdseg@gmail.com>
+
+pkgname=ttyrec
+pkgver=1.0.8
+pkgrel=2
+pkgdesc="A tty recorder and player"
+arch=('i686' 'x86_64')
+url="http://0xcc.net/ttyrec/index.html.en"
+license=('BSD')
+depends=('glibc')
+source=("http://0xcc.net/ttyrec/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('ef5e9bf276b65bb831f9c2554cd8784bd5b4ee65353808f82b7e2aef851587ec')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make CFLAGS+="-DSVR4 -DHAVE_inotify -D_XOPEN_SOURCE=500"
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ # install executable files
+ install -Dm755 ttyrec ${pkgdir}/usr/bin/ttyrec
+ install -Dm755 ttyplay ${pkgdir}/usr/bin/ttyplay
+ install -Dm755 ttytime ${pkgdir}/usr/bin/ttytime
+ # install README
+ install -Dm644 README ${pkgdir}/usr/share/doc/${pkgname}/README
+ # install man page
+ install -Dm644 ttyrec.1 ${pkgdir}/usr/share/man/man1/ttyrec.1
+ install -Dm644 ttyplay.1 ${pkgdir}/usr/share/man/man1/ttyplay.1
+ install -Dm644 ttytime.1 ${pkgdir}/usr/share/man/man1/ttytime.1
+}