summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKarel Kočí2016-12-05 08:14:58 +0100
committerKarel Kočí2016-12-05 08:18:04 +0100
commit1a587a652d1fb54a9a115606905a76ca28f0840c (patch)
tree02f64cc3ea58c6da9940d0ece6fe8d08a4a53cf8 /PKGBUILD
downloadaur-1a587a652d1fb54a9a115606905a76ca28f0840c.tar.gz
Create ttysterm package
Exeecutable it installs is named sterm, but because there is other project named sterm alreary in aur tty prefix is added to signal that this is terminal serial console, not graphical terminal.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6828f2c9dfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Karel Koči <cynerd@email.cz>
+pkgname=ttysterm
+pkgver=20160921
+pkgrel=1
+pkgdesc="Simple serial terminal"
+arch=('i686' 'x86_64')
+url="https://rtime.felk.cvut.cz/gitweb/sojka/sterm.git"
+license=('GPL3')
+depends=('lockdev')
+makedepends=('git')
+#changelog="debian/changelog"
+source=("$pkgname::git://rtime.felk.cvut.cz/sojka/sterm.git"
+ "Fix-install-strip.patch"
+ "known-lockdev-bug.patch")
+md5sums=('SKIP'
+ 'e37c9b06de817993830efe9e277e740c'
+ '5df1b7923840120638c8a5ee39ed9118')
+
+prepare() {
+ cd "$pkgname"
+ # Reset to specified version
+ git reset --hard $pkgver
+ # Fix install strip
+ patch -i $srcdir/Fix-install-strip.patch
+ # Document known bug with lockdev and Systemd
+ patch -i $srcdir/known-lockdev-bug.patch
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" PREFIX="/usr" install
+}