summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Houghton2017-06-29 14:08:42 -0400
committerJames Houghton2017-06-29 14:08:42 -0400
commit910317f82949d53cdf44717c202f7957bd8edf9e (patch)
tree034757c2472a3217f51653159dbcc374d2f2e477 /PKGBUILD
parent21cb16514487978fa6a684810a2933ae4bebdd92 (diff)
downloadaur-ttyvideo.tar.gz
Follow twa022's instructions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 251ddf49ef04..cf6bf25cd921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
pkgname=ttyvideo
-pkgver='0.0.1'
-pkgrel='1'
-pkgdesc="ttyvideo displays videos in the terminal."
-arch=('any')
+pkgver=0.0.1
+pkgrel=2
+pkgdesc="Play video in the terminal"
+arch=('i686' 'x86_64')
license=('MIT')
-depends=(opencv gstreamer gst-plugins-base)
-makedepends=(cmake)
-source=("https://github.com/jamesthoughton/ttyvideo/archive/0.0.1.tar.gz")
+depends=('opencv' 'gst-plugins-base')
+makedepends=('cmake')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/jamesthoughton/${pkgname}/archive/${pkgver}.tar.gz")
url='https://github.com/jamesthoughton/ttyvideo'
-md5sums=('862c8cf756ad896f82654565ffc7f5ad')
+sha256sums=('ecceca05dcfd94cadd0f17f58e3e98a93f5ee7ffe70a72e6935edf5e4a73fcc2')
build() {
- cd $srcdir/$pkgname-$pkgver
- cmake .
- make
+ cd "${pkgname}-${pkgver}"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
}
package() {
- cd $srcdir/$pkgname-$pkgver
- install -Dm 755 ttyvideo $pkgdir/usr/bin/ttyvideo
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}