summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Muehlhaeuser2019-06-04 23:50:19 +0200
committerChristian Muehlhaeuser2019-06-04 23:50:19 +0200
commit592095c81280d4366e05684cf868dd6f9bcfc9c5 (patch)
treeefedf683d5045f2656854fe167b7c2a5290f4d9c /PKGBUILD
parentd0a4ed4165ace86bdb4ce9070ca5eecb44f84300 (diff)
downloadaur-592095c81280d4366e05684cf868dd6f9bcfc9c5.tar.gz
Added missing dependencies and separated the build process
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f55291adde7a..b6bf969998e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Jose Riha <jose1711 gmail com>
+# Maintainer: Christian Muehlhaeuser <muesli at gmail dot com>
pkgname=tuhi-git
pkgver=20190503
-pkgrel=1
+pkgrel=2
pkgdesc="DBus daemon to access Wacom SmartPad devices"
arch=('any')
-depends=(python-svgwrite)
+depends=('python' 'python-svgwrite' 'python-xdg')
makedepends=('git' 'python-setuptools')
url="https://github.com/tuhiproject/tuhi"
license=('GPL2')
@@ -17,9 +18,14 @@ pkgver() {
git log -1 --format="%cd" --date=short | sed "s|-||g"
}
+build() {
+ cd ${pkgname%-git}
+ python setup.py build
+}
+
package() {
cd ${pkgname%-git}
- python setup.py install --root="$pkgdir" --optimize=1
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm755 tools/tuhi-live.py "${pkgdir}/usr/bin/tuhi-live.py"
install -Dm755 tools/tuhi-kete-sandboxed.py "${pkgdir}/usr/bin/tuhi-kete-sandboxed.py"
install -Dm755 tools/parse_log.py "${pkgdir}/usr/bin/parse_log.py"