summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJose Riha2019-05-31 00:03:23 +0200
committerJose Riha2019-05-31 00:03:23 +0200
commitd0a4ed4165ace86bdb4ce9070ca5eecb44f84300 (patch)
treed8416dc35c02f67ab6b12013c1f7a9b76564504e /PKGBUILD
downloadaur-d0a4ed4165ace86bdb4ce9070ca5eecb44f84300.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f55291adde7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=tuhi-git
+pkgver=20190503
+pkgrel=1
+pkgdesc="DBus daemon to access Wacom SmartPad devices"
+arch=('any')
+depends=(python-svgwrite)
+makedepends=('git' 'python-setuptools')
+url="https://github.com/tuhiproject/tuhi"
+license=('GPL2')
+source=(git+https://github.com/tuhiproject/tuhi)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+package() {
+ cd ${pkgname%-git}
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm755 tools/tuhi-live.py "${pkgdir}/usr/bin/tuhi-live.py"
+ install -Dm755 tools/tuhi-kete-sandboxed.py "${pkgdir}/usr/bin/tuhi-kete-sandboxed.py"
+ install -Dm755 tools/parse_log.py "${pkgdir}/usr/bin/parse_log.py"
+ install -Dm755 tools/kete.py "${pkgdir}/usr/bin/kete.py"
+ install -Dm755 tools/tuhi-live.py "${pkgdir}/usr/bin/tuhi-live.py"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/tuhi/README.md"
+}