summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAustin Riba2018-09-06 20:56:24 -0700
committerAustin Riba2018-09-06 20:56:24 -0700
commit37a5fa8753377e682d397eef2837cd4cf16337c5 (patch)
tree2d089846b6a47aa95be4ebc34a2cc081e66248af /PKGBUILD
downloadaur-37a5fa8753377e682d397eef2837cd4cf16337c5.tar.gz
Initial commit v1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c236b3eab5ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Austin Riba <ausin@m51.io>
+pkgname=tuimoji
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A terminal based emoji browser"
+arch=('any')
+url="https://github.com/Fingel/tuimoji"
+license=('GPLV3')
+depends=('python-setuptools' 'python-urwid' 'xclip')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('29990d30146387781643fc409865d687')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}