summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManuel Hüsers2021-12-13 12:45:04 +0100
committerManuel Hüsers2021-12-13 12:47:40 +0100
commitbf2e2cd7893f3aa6aad66d090043d5e503182b61 (patch)
treea645e4a9ffe48a7688060b6337718b821d184f9d /PKGBUILD
parent080c776289930b82ca91cac4a8430b95b1848e55 (diff)
downloadaur-bf2e2cd7893f3aa6aad66d090043d5e503182b61.tar.gz
Trigger rebuild for Python 3.10 and fix PKGBUILD
Thanks to @yochananmarqos for suggesting PKGBUILD changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01b726ee9ac5..4e0be917c62f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=tuned
pkgver=2.16.0
-pkgrel=1
+pkgrel=2
pkgdesc='Daemon that performs monitoring and adaptive configuration of devices in the system'
arch=('any')
url="https://github.com/redhat-performance/${pkgname}"
@@ -18,14 +18,19 @@ install="${pkgname}.install"
source=("https://github.com/redhat-performance/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('7f0b858c35fb9695703f04177af074555de59a7a3e94ec0b7e28357584d4502d')
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ mv libexec lib
+
+ sed -i 's/libexec/lib/g' Makefile
+ sed -i 's/sbin/bin/g' Makefile
+}
+
package() {
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}"/{run,var}
- mv "${pkgdir}"/usr/sbin/* "${pkgdir}"/usr/bin/
- mv "${pkgdir}"/usr/libexec/tuned/* "${pkgdir}"/usr/lib/tuned/
- rm -r "${pkgdir}"/run "${pkgdir}"/usr/sbin "${pkgdir}"/usr/libexec
-
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/tuned.service" "${pkgdir}/usr/lib/systemd/system/tuned.service"
+ install -Dm644 tuned.service "${pkgdir}/usr/lib/systemd/system/"
}