summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2020-04-04 21:17:26 +0200
committerChristopher Arndt2020-04-04 21:17:26 +0200
commit2eeec5507faeb7629f17a3aae604cf7f8f28efa9 (patch)
treeb3fd69d45b6afaf74bd0fd0d9cf8a5b7a4087c6f /PKGBUILD
parentde033cfe4c129ea6cae037379c78f6c30e0394ec (diff)
downloadaur-2eeec5507faeb7629f17a3aae604cf7f8f28efa9.tar.gz
Fix compile error with recent GCC
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c35859997851..0d39ae10b12b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=tunefish4
pkgver=4.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="An additive wavetable-based synthesizer VST plugin"
arch=('x86_64')
url="http://www.tunefish-synth.com/"
@@ -10,8 +10,10 @@ url="http://www.tunefish-synth.com/"
license=("GPL3")
groups=('vst-plugins')
depends=('alsa-lib' 'freetype2' 'libglvnd')
-source=("https://github.com/paynebc/tunefish/archive/RELEASE_${pkgver//./_}.tar.gz")
-sha256sums=('89e549acbdc4dc1f5bf094b6ee3968d8adb651b5078da4057f814617ca307b42')
+source=("https://github.com/paynebc/tunefish/archive/RELEASE_${pkgver//./_}.tar.gz"
+ "juce-pixel.patch")
+sha256sums=('89e549acbdc4dc1f5bf094b6ee3968d8adb651b5078da4057f814617ca307b42'
+ '5569a557492a6a41bf5f0e6fa2d3ecabd02cf2e9859c96401d0a53eaefa2c7d4')
prepare() {
@@ -24,6 +26,9 @@ prepare() {
JuceLibraryCode/modules/juce_audio_processors/format_types/juce_VSTPluginFormat.cpp; do
sed -i -e 's|public.sdk/source/vst2.x|vst36|g' "$file"
done
+
+ msg2 "Patching JUCE graphics..."
+ patch -p0 -N -i "${srcdir}/juce-pixel.patch"
}
build() {