summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2023-09-12 10:33:30 +0200
committerChristopher Arndt2023-09-12 10:33:30 +0200
commit239c47eea03444354e0edba49ce2155bdbc813a6 (patch)
treec3c68ead23b4895221d9b24e86e7fd243662da6e /PKGBUILD
parentf6087e846e167c95f89ca6c95ca945a415278264 (diff)
downloadaur-239c47eea03444354e0edba49ce2155bdbc813a6.tar.gz
Remove obsolete JUCE patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 2 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3688efcc6c71..7224a1389882 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,11 +14,8 @@ depends=(webkit2gtk)
makedepends=(git vst2sdk)
provides=($_pkgname)
conflicts=($_pkgname "${_pkgname}-vst-bin")
-source=("$_pkgname::git+https://github.com/paynebc/tunefish.git"
- 'juce-pixel.patch')
-sha256sums=('SKIP'
- 'c0b274515dadd14b530c35517d6fb3749b861344cec90c12eef965c9bca3e479')
-
+source=("$_pkgname::git+https://github.com/paynebc/tunefish.git")
+sha256sums=('SKIP')
pkgver() {
cd $_pkgname
@@ -29,22 +26,14 @@ pkgver() {
echo $version.r$revision.$hash
}
-prepare() {
- cd $_pkgname
- echo "Patching JUCE graphics..."
- patch -p1 -N -r - -i "${srcdir}/juce-pixel.patch" | :
-}
-
build() {
cd $_pkgname/src/tunefish4/Builds/LinuxMakefile
-
export CPPFLAGS="$CPPFLAGS -I/usr/include/vst36"
make
}
package() {
cd $_pkgname
-
install -Dm755 src/tunefish4/Builds/LinuxMakefile/build/Tunefish4.so \
-t "$pkgdir"/usr/lib/vst
install -Dm644 patches/tf4programs/* \