summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManiacTwister2020-02-22 21:02:11 +0100
committerManiacTwister2020-02-22 21:02:11 +0100
commit8eab45916695b31ca56cafd7aeb7b3c9d9851f2f (patch)
tree449e963c1a1286ed04d03f49069abaea79c40408 /PKGBUILD
downloadaur-8eab45916695b31ca56cafd7aeb7b3c9d9851f2f.tar.gz
Initial release, version release.0.6.r7.gf02ebdb
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d16801c49766
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: ManiacTwister <aur@maniactwister.de>
+pkgname=tunneller-git
+pkgver=release.0.6.r7.gf02ebdb
+pkgrel=1
+pkgdesc='Tunneller allows you to expose services which are running on localhost, or on your local network, to the public internet.'
+arch=('x86_64')
+url='https://github.com/skx/tunneller'
+license=('GPL')
+makedepends=('git' 'go-pie')
+source=("$pkgname::git+https://github.com/skx/tunneller.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare(){
+ export GOPATH="$srcdir"/gopath
+ mkdir -p gopath/src/github.com/tunneller
+ cp -r $pkgname/* gopath/src/github.com/tunneller
+}
+
+build() {
+ cd "gopath/src/github.com/tunneller"
+
+#go install
+ go install \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -v ./...
+}
+
+package() {
+ install -Dm755 gopath/bin/tunneller "$pkgdir"/usr/bin/tunneller
+}
+