summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Schweikert2024-02-14 16:14:29 +0100
committerFlorian Schweikert2024-02-14 16:15:32 +0100
commite5c29bf0b416ea6e9100a673a0df5a289f618428 (patch)
tree7ef4267e49ec9784e625d28dea1a74416bdbf6e0 /PKGBUILD
downloadaur-e5c29bf0b416ea6e9100a673a0df5a289f618428.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c01c444a249
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Florian Schweikert <kelvan@ist-total.org>
+pkgname=tunslip6-ng
+pkgver=4.9
+_branch=release/v${pkgver}
+pkgrel=1
+pkgdesc="tool to establish an IPv6 SLIP tunnel interface"
+arch=('i686' 'x86_64' 'armv7h')
+url="http://www.contiki-ng.org/"
+license=('BSD')
+depends=('glibc')
+optdepends=()
+conflicts=('tunslip')
+source=(https://raw.githubusercontent.com/contiki-ng/contiki-ng/${_branch}/tools/serial-io/tunslip6.c
+ https://raw.githubusercontent.com/contiki-ng/contiki-ng/${_branch}/tools/serial-io/tools-utils.c
+ https://raw.githubusercontent.com/contiki-ng/contiki-ng/${_branch}/tools/serial-io/tools-utils.h
+ https://raw.githubusercontent.com/contiki-ng/contiki-ng/${_branch}/LICENSE.md)
+
+sha256sums=('64107f35495496e8a68c4ac5fffdbe71d5095b3435eb1f4360ae57b21431da00'
+ 'a53336f55b87382c3f13011b7c908fa1839316ecc2f4a595f7f7275c6fac82ae'
+ 'b9e979dc1da9f485e731c0052f4c391d1d0c2f7d6ad13b97c8d8f75ad9b01dfd'
+ 'cbdd874f179d9cb90784c20c81e91d1a6ad92facce008ff2306545deefb11255')
+
+build() {
+ gcc tools-utils.c tunslip6.c -o tunslip6
+}
+
+package() {
+ install -D -m755 tunslip6 "${pkgdir}/usr/bin/tunslip6"
+ install -D -m644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}