summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Werkmeister2015-11-26 21:45:45 +0100
committerLucas Werkmeister2015-11-26 21:45:45 +0100
commit06c30a797ca16f56c8a79b78f048185f96e57b1a (patch)
treea30b02b8695c9ee4c50241ceb83ffcecf8060b32 /PKGBUILD
parent4f76e4cd5d9e379b50d53a146f86e668ad2230b3 (diff)
downloadaur-turpial-git.tar.gz
Fix dependencies
Add missing qt dependencies (thanks to AUR user kaczus for the info!), and make both gtk and qt dependencies optional.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e72c89d1f5d..323ad27e6338 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,15 @@ pkgdesc="A multi-interface Twitter client written in Python"
arch=(any)
url=http://turpial.org.ve/
license=(GPL3)
-depends=(gstreamer0.10-python hspell libturpial-git notification-daemon python2-babel python2-jinja
- python2-notify python2-pyqt4 python2-simplejson)
+depends=('gstreamer0.10-python' 'hspell' 'libturpial-git' 'notification-daemon' 'python2-babel' 'python2-notify' 'python2-simplejson')
+optdepends=(
+ 'pygtk>=2.12: GTK user interface'
+ 'aspell: GTK user interface'
+ 'gnome-spell: GTK user interface'
+ 'python2-gtkspell>=2.25.3: GTK user interface'
+ 'python2-pyqt4>=2.12: Qt user interface'
+ 'python2-jinja>=2.6: Qt user interface'
+)
makedepends=(git python2-setuptools)
provides=(${pkgname%-*}=$pkgver)
conflicts=(${pkgname%-*})